General Enquiries


Phones and tablets compatible with the Yoco Go card machine


Smartphones and tablets are ever evolving and new brands are surfacing on a regular basis. For this reason we have listed the specifications for devices that will work with your Yoco Go card machine. 

Use these as a guideline for the phones and tablets that are compatible with the card machine.

NOTE: these are basic guidelines and specifications may vary from device to device. You can check the specifications of your device at gsmarena.com.  

Android


  • Your Android device must be running Android 4.2 or higher.
  • Your device should have 2GB RAM or higher.
  • You must run an updated version of the Yoco app: Version 3.3.0 or higher for Android.
  • Your phone should be Samsung Pay compatible.

You can check if your Android device is supported here.

 

iOS


  • Latest iOS software version or iOS 9.3.5 and above.
  • An updated version of the Yoco app: Version 2.18.0 build 3 or higher for iOS.

You can check if your iOS device is supported hereMost Apple iOS devices running the latest iOS version are compatible. 

Help us improve our Help Centre. Was this article helpful?

Have more questions? Contact us now