Before You've Signed Up


What smartphone or tablet do I need to use Yoco?


Yoco works with iOS (Apple) and Android devices.

  iOS   Android

The Wireless card readers are both compatible with the following Apple (iOS) devices:

   iPhone 4S (and above)

   iPod Touch

   iPad 2 (and above)

  IMPORTANT: Please note that your Apple device must be running iOS 8 or later.

 

Devices definitely not supported


   Blackberry

  Windows Phone

  Vodacom Smart 4 mini

  Alcatel

  Hisense

  Vodafone Smart Tab

  Acer

  Karbonn

  Smartpoynt

  Mediatek chipset

  Redmi

  Sony Experia E4

  ZTE Blade C310

  Huawei Ascend Y220

Help us improve our Help Centre. Was this article helpful?

Have more questions? Contact us now